Bank Forward News

Friday April 07 2017

Your Online Banking Data, More Secure.

On April 11, 2017, we will be enhancing our online banking systems to maintain the highest standards for our data security and to align with industry best practices. And this means you might notice a few changes.

Here’s the scoop (put technically)

Microsoft has set a sunset date of April 11, 2017 for desktop operating systems that do not support Transport Layer Security (TLS) 1.2; TLS is a protocol that ensures secure encryption in an online connection, and version 1.2 is considered to be the most secure.

What this means

Your computer’s operating system or web browser might need to be updated. Please check the listing below to verify if your operating systems and browsers support TLS 1.2. If you are running Microsoft XP/Vista, Microsoft Windows Server 2008 and below, or Microsoft Internet Explorer 9 or 10, you may be unable to access your online banking services.

Browsers and Operating Systems TLS 1.2 Compatibility Notes
Microsoft Edge Compatible by default
Microsoft IE Desktop and mobile version 11 Compatible by default
Microsoft IE Desktop versions 9 and 10 Capable when run in Windows 7 or newer, but not enabled by default
Firefox 27 and higher Compatible by default
Google Chrome 38 and higher Compatible by default
Mobile Safari versions 5 and higher Compatible by default
Microsoft Windows Server 2008 R2 and higher Compatible by default
Microsoft Windows Server 2008 and below Not compatible with TLS 1.2
Microsoft Windows 7, 8.0, 8.1, and 10 Compatible by default
Microsoft XP/Vista and below Not compatible with TLS 1.2

As always, if you have any questions, feel free to contact us by phone at 800-450-3115 or email us here.

Your Online Banking Data, More Secure. Back to All Articles